Why am I getting an error message that the website connection is not secure?

You are seeing the message because we have secured online bidding on MaxSold to support the highest levels of security, performance, and reliability that's available today.

By using the browser you are NOW using on MaxSold (or on any other site), your credentials are NOT secure.  You must either install an alternate browser such as Chrome or Firefox or upgrade to Internet Explorer 11 or Microsoft’s new Edge browser.


How do you tell which browser you are using?
Use this link: https://whatbrowser.org/


Get one of the below free browsers:

Chrome: https://www.google.com/chrome/
FireFox: https://www.mozilla.org/en-US/firefox/new/
Microsoft: https://www.microsoft.com/en-ca/download/details.aspx?id=48126
Mac, Safari: https://support.apple.com/downloads/safari

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.
Powered by Zendesk